Inforce Computing Forums

inforce computing forums to discuss about inforce products

Linux V1.0 boot failure

Questions and discussions related to Inforce 6601 Micro SOM

by tamo2 » Fri Sep 14, 2018 6:18 pm

Hi,
We have been seeing a boot issue with Linux V1.0 release. We use 6601 SOM with the 6601 Dev Kit.
The symptom is, the system stops during the boot.
I attached a log file which includes traces of 2 failure cases. I marked the start of the log as "Boot Failure [1]" and "Boot Failure [2]" respectively.
To get this log, I tried power cycling 20 times and got 2 failures.

We have multiple 6601 dev kits and seems to occur on any system.
The kernel, meta-data and filesystem are pre-built files from IFC6601_Debian_Linux_BSP_880519_V1.0.

Can you please look into this ASAP?
Thanks,
tamo2
tamo2
 
Posts: 27
Joined: Tue Jun 13, 2017 4:39 pm

by ashwin » Wed Oct 03, 2018 10:48 pm

Hi Tamo,

Please ensure that you flash the meta-binaries present in the release and then re flash the 1.0 debian release.

Best Regards,
Ashwin
ashwin
 
Posts: 44
Joined: Wed Jul 01, 2015 10:07 pm

by tamo2 » Thu Oct 11, 2018 12:37 pm

Ashwin,
Thanks for the response.

> Please ensure that you flash the meta-binaries present in the release and then re flash the 1.0 debian release.

I am sure I did that.

Just FYI, the same kind of issue occurs with Dragonboard 820c, and I posted a question to the forum: https://discuss.96boards.org/t/boot-fai ... oot/5931/3

We are still looking for a fix, or a work around (such as watchdog). Any help is appreciated. Thanks,
tamo2
tamo2
 
Posts: 27
Joined: Tue Jun 13, 2017 4:39 pm


Return to INFORCE 6601™ MICRO SYSTEM-ON-MODULE (SOM)

cron

Contact Us.