Inforce Computing Forums

inforce computing forums to discuss about inforce products

i2C Bus Number on 6601 Development Board

Questions and discussions related to Inforce 6601™ development kit

by tamo2 » Fri Dec 29, 2017 1:54 pm

Hi. What is the i2c bus number(s) for the two camera connectors (J1 and J2)? We tried using i2cdetect for buses 0, 6,7,8, and 12, but the only bus that seemed to work was bus 0.
Thanks,
Tamo
tamo2
 
Posts: 26
Joined: Tue Jun 13, 2017 4:39 pm

by ashwin » Wed Jan 03, 2018 3:42 am

Hi Tamo,

The CCI i2c lines are dedicated for camera use only and do not ennumerate on sysfs(/dev/i2cxx). i2cdetect would not work on these lines.

Best Regards,
Ashwin
ashwin
 
Posts: 41
Joined: Wed Jul 01, 2015 10:07 pm

by tamo2 » Wed Jan 03, 2018 1:45 pm

Hi Ashwin,
We are developing our own camera interface board (and driver) that will attach to J1 or J2. We would like to know if the i2c is working on J1 and J2. How can we test the i2c on these modules? Also, our driver would be something like this: https://elixir.free-electrons.com/linux ... a/ov9740.c. Will the i2c code just work as per this driver?
Thanks,
Tamo
tamo2
 
Posts: 26
Joined: Tue Jun 13, 2017 4:39 pm

by ashwin » Thu Jan 18, 2018 2:50 am

Hi Tamo,

You can check the i2c sensor probe in the driver to check if i2c on the camera works.

This will usually show up in the kernel logs when the probe succeeds or fails.

eg:-
<sensor name>: probe succeeded
ashwin
 
Posts: 41
Joined: Wed Jul 01, 2015 10:07 pm


Return to INFORCE 6601™ DEVELOPMENT KIT

Contact Us.