Inforce Computing Forums

inforce computing forums to discuss about inforce products

How to Recreate <Rootfs>.img

Questions and discussions related to Inforce 6601™ development kit

by tamo2 » Mon Jan 22, 2018 7:19 am

Hi. I can flash the rootfs-ifc6601-v0.5.img, provided by by Inforce Debian_Linux_BSP using the fastboot utility. I am now trying to recreate rootfs-ifc6601-v0.5.img. I issue the following commands in a Ubuntu 16.04 Virtual box:

$gunzip rootfs-ifc6601-v0.5.img.gz
$simg2img rootfs-ifc6601-v0.5.img rootfs-ifc6601-v0.5.img.raw
$sudo su
$mkdir rootfs
$mount -o loop rootfs-ifc6601-v0.5.img.raw rootfs
$sudo make_ext4fs -L rootfs -l 55G -s test.img rootfs/

The test.img created in the last step is the same size as the original rootfs-ifc6601-v0.5.img. When I run fastboot flash userdata test.img, the output of fastboot seems ok:

target reported max download size of 536870912 bytes
erasing 'userdata'...
OKAY [ 0.028s]
sending sparse 'userdata' 1/6 (518183 KB)...
OKAY [ 12.499s]
writing 'userdata' 1/6...
OKAY [ 5.190s]
sending sparse 'userdata' 2/6 (524246 KB)...
OKAY [ 13.426s]
writing 'userdata' 2/6...
OKAY [ 7.669s]
sending sparse 'userdata' 3/6 (524183 KB)...
OKAY [ 14.751s]
writing 'userdata' 3/6...
OKAY [ 15.826s]
sending sparse 'userdata' 4/6 (522012 KB)...
OKAY [ 14.025s]
writing 'userdata' 4/6...
OKAY [ 10.603s]
sending sparse 'userdata' 5/6 (517040 KB)...
OKAY [ 13.776s]
writing 'userdata' 5/6...
OKAY [ 10.596s]
sending sparse 'userdata' 6/6 (25550 KB)...
OKAY [ 0.636s]
writing 'userdata' 6/6...
OKAY [ 0.268s]
finished. total time: 119.345s

When I reboot the IFC6601 development board it displays the Linux logo but eventually hangs and I end up with a black screen. Can you please tell me what I could be doing incorrectly?
Posts: 29
Joined: Tue Jun 13, 2017 4:39 pm

by ashwin » Mon Jan 22, 2018 9:40 pm

Hi Tamo,

Please use the following make-ext4fs binary instead.

wget ... _amd64.deb
sudo dpkg -i --force-all android-tools-fsutils_4.2.2+git20130218-3ubuntu41+linaro1_amd64.deb

And use the following command instead.

sudo make_ext4fs -o -L rootfs -l 55G -s test.img rootfs/

Hope this helps

Best Regards,
Posts: 60
Joined: Wed Jul 01, 2015 10:07 pm

by tamo2 » Tue Jan 23, 2018 8:15 am

Hi Ashwin,
Thank you for the response. Your instructions worked great.
Posts: 29
Joined: Tue Jun 13, 2017 4:39 pm



Contact Us.