SMART Wireless Computing - Forums

A discussion forum dedicated to SMART Wireless Computing community to discuss various topics about features and issues.

USB 3.0 Micro-USB B port not working?

Questions and discussions related to Inforce 6540

by ifc6540_user » Sun Oct 15, 2017 11:19 pm

I'm running the builtin Ubuntu software (Linux linaro-gnome 3.10.40-ifc6540-v1.2+) on the Inforce 6540 and I can't get the USB 3.0 Micro-USB B port to work as a client/peripheral/slave or OTG slave interface. Connecting it to a host doesn't show ANY USB activity. I looked at the Linux kernel configuration and it's supposed to have the Google Android Composite Gadget support (USB Gadget Support) built in. Something is missing to pair with the driver with the underlying USB phy driver for that Micro-USB B interface (if it exist). Since this is not working, I doubt I can reconfigured it to work with any USB Gadget USB driver support (I tried, it doesn't work); I'm interested in the Multifunction Composite Gadget which provides a serial, network, and mass storage interface when connecting to a host. None of this is working. Anyone got this working that can help? I tried downloading the latest Linaro kernel, building it's not compatible with the rest of the existing ifc6540 software.

On a side note, I noticed the USB A ports don't really work etiher (or it's not loading the drivers properly to make the attached device usable); I tried several USB devices (USB to serial adapters, USB to ethernet adapters, USB thumb drives, etc) but I can't seem to get them to enumerate and connect successfully.

The only USB instance that works is when I put it in fastboot mode to program; the Google USB driver works on the USB 3.0 Micro-B interface in that case. However, this is bootloader / recovery SW and not the Linux kernel. I also noticed I couldn't configure the kernel to load the USB device drivers as modules instead of built-in. This Linux kernel has a lot of limitations. Please advise.

Posts: 1
Joined: Thu Oct 12, 2017 4:34 pm

by Sundeep » Tue Nov 21, 2017 1:45 am

Hi Andy,
The Inforce 6540 has one Type A USB 3.0 connector, one uUSB 3.0 connector and HS USB 2.0 x2 type A connectors. OTG is not supported on this platform.

Posts: 46
Joined: Wed Jul 01, 2015 9:10 pm

Return to INFORCE 6540™


Contact Us.